SABnzbd

Wiki

Incorrect or missing information? Configure

This Wiki page is for an older version of SABnzbd.
You can download the most recent stable version (SABnzbd 2.0) on our downloads page.

SABnzbd comes with sensible defaults to work, however, there are plenty of options and tweaks to tailor SABnzbd to your needs.
View the relevant page for more information on what an option does and more.

All configuration data is stored in the so-called INI file. Which INI file used, you can see on the Configuration main page.
Default locations for each operating system can be found in Folder Setup.

SABnzbd relies on using existing utilities to extract, repair, and process files once they have been downloaded.
Some of these utilities are provided with SABnzbd while some require the user to install, also some may only be optional depending on how you use SABnzbd.


SSL not available

In order to connect to your newsserver using SSL you need to install pyOpenSSL and OpenSSL (sometimes provided in 1 package). Installation depends on your platform. Windows and macOS packages already include the required files and should work after installation of SABnzbd.

Ubuntu:

sudo apt-get install python-openssl

Running from source:

pip install pyopenssl


yEnc not available

Posts on usernet are coded in the yEnc format, decoding this during the downloading using Python is not very efficient. Therefore we implemented this part in C for a big gain in performance.

Installing yEnc can only be done when you have a C-compiler installed. This is usually the case on Unix systems, for Windows and Apple macOS see the specifc guides how to install yEnc.
With a compiler and pip installed, you can simply run this command:

pip install http://www.golug.it/pub/yenc/yenc-0.4.0.tar.gz